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The Control Software of the XD-Subwoofers

IMPORTANT: 
This guideline is applicable for XD Series subwoofers/speakers shipped from 
March 2017, featuring the imprints on the amplifier module as seen below:
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Software version/build 

This manual describes the functions of version 1.04., build 118648. Checking version and build is possible under HELP > ABOUT in 
the CONTROL CENTER window (see graph. 1 on next page). PLEASE MAKE SURE you always use the latest software, and replace 
older versions/builds by the latest software available from www.avantgarde-acoutsic.de (section DONWLOADS), as explained in the 
subsequent paragraphs. NOTE: Older software versions will be automatically overwritten (no need to de-install).

Installing the PC/Mac-Software 

System requirements for installing the control software: Windows operating system (32 oder 64 Bit) or Mac OS version 10.5.8 or 
higher and an Ethernet or USB port. 

Before installation, download the installation program (“msi“ file) according to your Windows operating system (32 or 64 Bit), or 
download the “app.zip“ file for Mac OS from the following website:

http://www.avantgarde-acoustic.de under DOWNLOADS

NOTE: Information on 32 or 64-Bit Windows is found in the Control Panel under SYSTEM or under PC-INFO, with Mac OS under 
APPLE > ABOUT THIS MAC.

The file will usually be saved to the “Downloads” folder  (if not defined otherwise). As soon as the file is completely downloaded, 
open the file with a double-click and follow the given installation guidelines. After the installation is completed, an AVANTGARDE XD-
SERIES CONTROL symbol will appear on the desktop (see graphic below).

NOTE on Ethernet port: The Ethernet port of the subwoofers uses a max. bitrate of 10 Megabit/s. Thus with network hubs that only 
support 100 Megabit/s an according 10/100-switch will be necessary.

Windows is a registered trade mark of Microsoft Corporation in the USA and other countries. Mac OS is a registered trade mark of 
Apple Computers Inc. in the USA and other countries.

CAUTION! The signal processor and the operating software form a very effective “tool”, enabling the user to make very fine but also 
grave adjustements of the subwoofers behavior.

Every adjustment of parameters should therefore be made with consideration and expertise, as extreme changes may cause serious 
damage to the subwoofers drivers or amplifiers!

Connecting the XD Subwoofer

Connect the computer via USB type-A/B or Ethernet (availabilty depending on speaker model) to the according input socket in the 
rear of the subwoofer. It is also possible to use both connections (where available) on the same computer (e.g. right subwoofer via 
USB, left subwoofer via Ethernet). 

Using a network switch or splitter, multiple subwoofers can be controlled at the same time (e.g. all modules of a 2/4/6 fold BASSHORN 
setup) via Ethernet (where available), even free ports of an existing household network may be used. If the computer has more than 
2 USB ports (or if a USB hub is available), connecting multiple subwoofers is also possible via USB connections.



Opening the Control Software 

Clicking to the AVANTGARDE XD CONTROL symbol will firstly open the CONTROL CENTER (graph. 1). A list of all connected and 
powered subwoofers will appear, in the brackets under ALL UNITS the number of ONLINE subwoofers will be displayed. Below a 
status line will be opened for each connected subwoofer:

❶ Button for muting the subwoofer. Red while muted. Clicking the same button in the ALL UNITS line mutes all connected subwoof-
ers simultaneously.

❷ Button for identifying a subwoofer. Clicking the button will cause the rear LEDs of the according subwoofer to flash for several 
seconds.

❸ Symbol for the status of the subwoofer. Green during operation, grey when connection is lost. While establishing a connection, a 
“Startup...” message appears.

❹ These 2 vertical beams serve as a basic level meter display.

❺ Display of the subwoofer name. The preset name may be overwritten by a user defined name here or or in the Configuration 
Window.

❻ Display of the hardware address (MAC-Address) of the Ethernet or USB port of the subwoofer. This address is the unique digital 
ID of the subwoofer.

❼ Display of the IP address or USB port number. Shows OFFLINE when the connection is interrupted.

❽ Button for opening the Configuration Window of an ONLINE subwoofer. Clicking the same button in the ALL UNITS line masks/
displays the complete listing of connected subwoofers.

Groups

Several subwoofers can be grouped (under a definable group name) for a shared setting of parameters, e.g. providing collective 
muting or level setting. Which parameters are accessible can be defined in the group’s settings. The affiliation to a certain group can 
be changed/swapped at any time.

Make new Group

PLEASE NOTE: Grouping speakers is ONLY RECOMMEDED when the parameters (GAIN/VOLUME, EQ settings etc.) of all grouped 
speakers are to be set to identical values! Grouping is NOT RECOMMENDED if the parameters have to differ, e.g. when the speakers 
are setup in different acoustics (e.g. one speaker in the corner, one speaker freely standing). IMPORTANT: Differing parameters are 
also the case when Avantgarde Acoustic HRS or HRM room compensation files are applied!

For setting up a new group go to the TOOLS > NEW GROUP menu.

The window now opening (see graph. 2) displays “Enter the name of the new group:“. In the listing of connected subwoofers (see 
graph. 1) a new line is opened with the group displayed (line “Group: …“).
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Clicking the button ❶ in graph. 3, a group can be opened or configured. In the window “Configure Group” members can be added or 
removed, and the group name or the “setup links” of simultaneously changed settings may be altered. 

The “Type” dropdown list ❷ opens the link options to define the shared, thus simultaneously changed, functions. Therefore select 
“Carbon Copy” (= factory setting) in the dropdown menu. Now all changes and setups executed with one of the subwoofers are 
automatically transferred and identically executed on all other group members.

Button ❸ of the “Configure Group” window opens the “Select Group Members” window to display and select available group mem-
bers. Then click to button ❹, which transfers all available subwoofers to the right into the field “Group Members”. Confirm with OK.
NOTE: Marking just one “Available Unit” or “Group Member”, just one subwoofer can be transferred between the 2 lists by using the 
one-arrow-buttons below button ❹. Lastly confirm with OK, also in the “Configure Group” window.

Delete Group

To delete a group, click to the according button ❺ in the “Group: ...” line. A warning will appear to have the deletion confirmed. If sub-
woofers are still affiliated to the group, an additional warning will appear, requiring an additional confirmation of the deletion progress.

Change Programm Password

To change the password go to TOOLS > CHANGE SOFTWARE PASSWORD. The window now opening displays “Enter Old Password:“, 
preprogrammed by the factory is “user“, to be entered in lower case letters and without the quotation marks. Then the “Enter New 
Password:“ line will appear, where the new password may be entered now. Last step is the “Confirm New Password:“ line. Making 
notes of the NEW PASSWORD is highly recommended!

Demo Mode

Even without a subwoofer connected to the computer, the program’s abilities can be explored by creating a virtual subwoofer. Go 
to the TOOLS menu and click to ENTER DEMO MODE. In the list of connected subwoofers, virtual subwoofers will appear, named 
DEMO…. Like with real subwoofers the button ❽ in graph. 1 will open the configuration window.

To leave this mode, go to TOOLS > LEAVE DEMO MODE.

Quit Program

To quit the program go to FILE > QUIT or close the program window.
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Operation and Configuration of XD-Subwoofer

For accessing the Configuration Window, click to the button ❽ in graph. 1 of the respective subwoofer. The Configuration Window will 
open in the MAIN screen. On the left side of the MAIN screen a colored LINK field will display the connection status of the respective 
subwoofer, when green the connection is established. 

TIPP: Clicking to all buttons ❽ in graph. 1, the Configuration Windows of all connected XD subwoofers can be opened (and operated!) 
in parallel. The Configuration Windows will open on top of each other(!), to keep them visible as separated windows, “click and hold” 
into a free area of the Configuration Window and pull it aside before opening the next Configuration Window. Afterwards all visible 
Configuration Windows can be placed freely on the screen. 

While a subwoofer is connected, any changes made are directly uploaded automatically and instantly, and will be audible directly! 
The settings may be saved onto the computer (COMPUTER) and/or onto the loudspeaker (SPEAKER) as a preset. When the  sub-
woofer is switched ON, always the lastly made settings will be effective (also see below).

Screen MAIN (graph. 4a)

❶ Button to change between MAIN and IN 1 screens.

❷ PRESETS COMPUTER: saves (“Store“) the current settings as a preset onto the computer (also see menu “File > Save“) and loads 
(“Load“) presets from the computer (also see menu “File > Open“) onto the subwoofer.

❸ PRESETS SPEAKER: saves (“Store“) the current settings as a preset onto the subwoofer and activates (“Load“) presets stored on 
the subwoofer. For saving, choose a free (named “Empty”) preset from the drop-down list, and enter a distinct name for the preset 
in the field above. Saving presets onto the subwoofer is the recommended method for storing user-made settings!

PLEASE NOTE: “Empty” presets can only be opened during the saving procedure! Please also see “How to...” on next page.

❹ LINK – connection status: green = connected, red = not connected (to be ignored when subwoofers are manipulated as GROUP).

❺ SPEAKER NAME – name of the subwoofer: can be changed by over-writing the name by a user-created name.

❻  GAIN fader to adjust the subwoofer’s playback level, to the right a level meter display, below a display and input field for the exact 
gain factor in dB. In this input field values can be entered with a precision of 0,01 dB.

TIPP: When just 1 connection is possible (1 x USB or 1 x Ethernet) to just 1 subwoofer, the settings made on the first subwoofer can 
be stored under PRESETS COMPUTER ❷ by the “Save” button (under a distinct name). Then plug the Ethernet or USB cable into the 
next subwoofer and “Load” the just saved preset onto this subwoofer. Consequently both subwoofers will then have identical settings.

❶ ❷

❸
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Protected factory programmed preset files (graph 4b)

The first 20 presets of the subwoofer (SPEAKER) contain 20 factory preset EQ curves ❶, which are protected and can thus not be 
over-written. For a detailed description of the sonic effects of these 20 filters, please refer to the printed manual of the respective 
loudspeaker model. Preset no. 1 is the “linear” factory setup.

Presets 21-80 are named “Empty”, and cannot be loaded, but just be used to save user created EQ settings.

How to create and save user created EQ filters

As a basis for user created filters, any setting of the first 20 factory-set presets can be loaded and then be varied by adjusting all 
availble parameters of up to 10 parametric EQs (see next page). Any adjustments made can then be saved (“Store”) onto the speaker 
(under PRESETS SPEAKER ❸).  Therefore choose a free (named “Empty”) preset from the drop-down list, and enter a distinct 
name for the preset in the field above (max. 16 characters). Then press “Store”. Saving presets onto the subwoofer (SPEAKER) 
is the recommended method for storing user-made settings!

How to upload user created (and third party) EQ filters

For activating a user created filter, select the relevant file (among number 21-80) from the drop down list ❶, then press “Load” under 
PRESETS SPEAKER ❸. A “Synchronizing” window will open and displays the upload progress. 

Preset files that have been created by third-party experts, e.g. room acoustic compensation curves (as offered through the Avantgarde 
Acoustic “Audio Holography” services HRS and HRM) can be uploaded to the speaker by using PRESETS COMPUTER ❷. Assuming 
the preset files are stored on the utilized computer, pressing “Load“ opens a browser window and lets you choose according preset 
files (nomenclature: xxx.preset) from the relevant location/folder on your computer.

Synchronisation of subwoofer amplifier display and software

The rotary button of the amplifier display overrules the preset selection via software. Thus when using the rotary button for selecting 
a new preset filter, the display will start counting with the number of the filter that was last selected by the rotary button, even if 
meanwhile a different filter was uploaded to the subwoofer by the computer. This is an intended behavior.  
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Screen IN 1 (graph. 5)

❶ Curve representing the current target response: Each of the 10 parametric filter points is represented by a Center Point (small 
numbered and colored square field). The resulting response of all activated filters is shown by the curvature of the white line. The 
filter parameters may partly also be changed by computer mouse operations:

– Adjusting center frequency by moving the square field horizontally
– Adjusting the gain (amplitude) by moving the square field vertically
– Adjusting the Q factor (bandwidth) by moving the square field horizontally with right mouse button pressed
– Switching filter ON or OFF by double clicking the square field

Symbols on the upper left of the graphic EQ window:
Ⓐ Enlarge display > full screen display and return to original display size
Ⓑ Save current curve as picture (PNG)
Ⓒ Fine adjusting mode ON or OFF
Ⓓ Superposition of active filter values ON or OFF

❷ GAIN fader to adjust the subwoofer playback level, to the right a level meter display, below a display and input field for the exact 
gain factor in dB. In this input field values can be entered with a precision of 0,01 dB. (identical to ❻ in graph. 4).

❸ ON/OFF field to activate/deactivate a filter (activated = blue, deactivated = grey)

❹ List field TYPE to select filter type (factory default and most versatile type: BELL)

❺ input/display field for the Center Frequency of the filter (values entered in Hz)

❻ input/display field for Q/BW (bandwidth of the filter). Select Q or BW by clicking to “Q” field

❼ input/display field for adjusting the gain/amplitude of the filter

NOTE: A tutorial PDF “Programming parametric EQ filters” is provided under DOWNLOADS on www.avantgarde-acoustic.de.

❽ High pass filter HPF: Input/display field for the lower crossover frequency (values entered in Hz, values < 20 Hz cause “Off”). In 
the field to the left the filter can be activated (blue) or deactivated (grey)

❾ High Pass Filter HPF: List field for selecting the filter type. Factory setting: Butterworth 24dB

This HPF filter is activated and programmed as a factory set SUBSONIC filter (20 Hz, -24 dB)! It can be shifted to higher fre-
quencies (in 1 Hz steps) for avoiding e.g. subsonic problems with LP playback. It may also be deactivated, for linearizing the response 
to below 20 Hz, but please note that this may limit the maximum SPL capacities of the subwoofers!
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❿ Low pass filter LPF: Input/display field for the upper crossover frequency (values entered in Hz, values > 20 kHz cause “Off”). In 
the field to the left the filter can be activated (blue) or deactivated (grey)

This LPF filter is activated and programmed as a factory set transition frequency towards the midrange horn! It can 
be shifted to any other frequency value, e.g. for achieving a slightly warmer and “richer” sound of singing voices by increasing the 
value (possible in 1 Hz steps), thus creating a deliberate “overlapping” with the midrange horn.

⓫ Low pass filter LPF: List field for selecting the filter type. Factory setting: Butterworth 24dB

⓬ MUTE button to mute the subwoofer (field turns red)

⓭ Button COMPRESSOR to open sub-menu window of the compressor configuration (see text below)

⓮ Rotary button DELAY with input/display field for deliberately setting a playback delay of the subwoofer. Select unit in the list field 
below: time or distance (distance will automatically be calculated to time values internally). Factory setting: 0 ms.

⓯ Level restriction LIMITER: Rotary button THR with input/display field for the threshold value. CHANGES NOT RECOMMENDED!

⓰ Level restriction LIMITER: Rotary button REL with input/display field for the release time. CHANGES NOT RECOMMENDED!

Window COMPRESSOR CHANGES NOT RECOMMENDED!

> Button BACK returns to the IN 1 screen
> Level display VU und GR (gain reduction)
> Rotary button THRESHOLD with input/display field for threshold value
> Rotary butoon ATTACK with input/display field for attack time
> Rotary button HOLD with input/display field for hold time
> Rotary button RELEASE with input/display field for release time
> Rotary button RATIO with input/display field for compression ratio
> Rotary button MAKEUP GAIN with input/display field for SPL compensation

Entering Passwords

After switching the subwoofer ON, normally the “User“ access level will be active, with immediate access to all described menus, 
buttons and fields. To gain access to higher levels, enter the according passsword under HARDWARE > ENTER PASSWORD.

PLEASE NOTE: Access to expert mode is restricted to specially trained professional users!

Changing Passwords

To change the password of the current access level go to menu HARDWARE > CONFIGURE > CHANGE PASSWORD. Changing 
requires that the current password is entered first, and then the new one, which will need to be repeated in an additional field for 
security reasons. Passwords for lower access levels may be entered directly and are explicitely displayed. Factory set password for 
“User” level: “user“, to be entered in lower case letters and without quotation marks.

Display Illumination

The closing time of the rear blue display illumination can be adjusted under HARDWARE > CONFIGURE > DISPLAY. As a factory 
preset DELAYED OFF is selected, which means that the display switches off (at the latest after 60 seconds) after the last settings 
have been made. If desired otherwise it can be programmed to permanent ON or permanently DIMMED state in this menu.

Locked State

In the lowest acces level LOCKED STATE a “key lock” mode is activated for the rear operating buttons. Therfore go to HARDWARE 
> LOCK UNIT. A message is displayed which informs that this level may only be exit by inputting the correct password. Confirm by 
clicking to OK.

To exit this “key lock” mode go to HARDWARE > ENTER PASSWORD to enter the password (Factory set password: “user“, to be 
entered in lower case letters and without quotation marks).



Backup/Restoring all Presets

For an occassional backup of all meanwhile programmed presets onto the computer(!) go to FILE > BACKUP PRESETS and select a 
folder (with a distinct name!) on the computer. For a later restoring (onto the subwoofer) of all backup presets go to FILE > RESTORE 
PRESETS and go to the according folder.

Uploading changed Factory Settings (Factory File)

Should Avantgarde Acoustic at any given time decide to define new Factory Settings, these may be uploaded under FILE > LOAD 
FACTORY FILE. Therefore save the new “Factory File” onto the connected computer. The new “Factory File” may likely be download-
able from the website www.avantgarde-acoustic.de or is sent out by eMail. 

As a Factory File overwrites (thus deletes) the currently existing PRESETS of the subwoofer, it is recommended that the currently 
existing presets are firstly saved and later restored as described in the above paragraph (Backup/Restoring...).

PLEASE NOTE: occasionally, using a direct Ethernet connection (between computer and speaker) for such an upload may fail, likely 
when a laptop computer is used that has WiFi internet access enabled and connected at the same time. Such parallel connectivity 
of Ethernet and WiFi may confuse the computer’s internal controller. In this case please disable the computer’s WiFi connections to 
the internet temporarily!

REMARKS 

Signal Path

Signals pass an input amplifier stage (GAIN), a high and low pass filter stage (HPF+LPF), a 10 band parametric equalization stage 
(PEQ), a signal delay stage (DELAY), a dynamics compressor (COMPRESSOR) and a level restriction (LIMITER). 

Software Versions

Should any of the software functions not work as described in this manual (e.g. access to EMPTY files, behavior of STORE and LOAD 
buttons etc.), it is adviseable to visit the website

www.avantgarde-acoustic.de

and open the DOWNLOADS menu, where the current software version is available. Then download and install the current/latest ver-
sion (no need to uninstall previous versions!), and recheck the functions.

Moreover, by sending a message to 

support@avantgarde-acoustic.de

configuration files (FFI) of each product/loudspeaker are available (please state product name and serial number!).


